Firmware update for Vividwireless modem

I have a vividwireless modem/router model number B315s-607 and am having problems connecting to some Apple devices. I am on firmware 21.323.03.00.1385 and have read that a new firmware is out (version 31.327.01.00.1385) which solves this problem. Is there any way to download the firmware manually to upgrade the device?

I have tried navigating to the settings/system update page and clicked on the online update, but the result shows my firmware is the latest.

I am not currently connecting to the internet via the Optus/vividwireless SIM, but rather have connected a LAN cable to my NBN router and am using this B315s as a wireless switch. Would this arrangement prevent me from getting an online update?

Comments

#1

ozzcaddy-MODERATOR wrote 24 weeks ago

By not having the modem connected to the Vividwireless network, it will not know if the modems firmware was updated or not.

To ensure the modem firmware is updated, I would suggest contacting Tech Support and have them log for your modem to be updated. This is normally done overnight, so you would need to leave the modem on overnight.

Tech Support: 1300 327 837

Adelaide, Brisbane, Melbourne and Sydney Customers (local time):
Monday to Friday 9am-10pm. Saturdays, Sundays and Public holidays from 9am-9pm.

Perth Customers (local time):
Monday to Friday 8am to 9pm. Saturdays, Sundays and Public Holidays from 8am to 8pm.

#2

Frosty-MODERATOR wrote 24 weeks ago

Updates for the vividwireless modems are delivered "over the air". So you would need to have the modem connected via its SIM to the vividwireless network for it to receive a firmware update. These updates are pushed out automatically, so as far as I am aware there isn't a manual update option that you can use.

If you do put the SIM back in and do a reboot, as Ozzcaddy suggested, leave it on overnight and see if it updates. If it doesn't, then you could post your IMEI number for the modem and I can pass this along to vividwireless and request that they push an update specifically for your modem (at least, they used to be able to do this, so I am assuming that it is still possible).

Let us know how you get on and whether you need any further help with it.

#3

sirzur wrote 24 weeks ago

I was afraid that the update can only come via the vividwireless network. The reason why I am using it as a wireless "bridge" is because I seems to have misplaced my SIM card.

Can I just purchase a new vividwireless SIM card to use? Failing that do you think it would be possible to just purchase an Optus SIM card to try?

#4

ozzcaddy-MODERATOR wrote 24 weeks ago

A different ISP Sim Card such as Optus, will not work in the Vividwireless Modem. The Vividwireless Sim Card and the Modems ID are registered on the Vividwireless network.

Is this a new modem or a second hand modem?

I don't know if you can purchase a Vividwireless Sim Card only. You should speak with Tech Support on the above phone number in Post #1.

#5

sirzur wrote 24 weeks ago

Yeah, it is a second hand one. I took out the SIM out of the modem not realising that they should be kept together.

Thanks for your help in this

#6

Tom wrote 23 weeks ago

Just to tag on to this, so I have a new modem with the same old version.

Only purchased/activated it today, so will it update overnight?

Manual Update didn't work, do I need to ping support to flag it?

#7

ozzcaddy-MODERATOR wrote 23 weeks ago

Tom, to what I understand it is just a matter of leaving the modem on overnight and the firmware will be updated over the air.

if you find it did not update, I would suggest calling Support (details in Post #1)

#8

Tom wrote 23 weeks ago

Thanks, it didn't update overnight.

Not that it's causing issues, so I'll leave it and see what happens.

Good way to test the update system ;)

Absolutely flying full speed even during peak to the local Optus CMTS

Down: 11.70 Mbps Up: 0.97 Mbps

https://web.acma.gov.au/rrl/site_search.site_lookup?pSITE_ID=301571

No shortage of fiber around here, yet the NBN roll out is HFC or very slow ADSL2.

#9

Tom wrote 22 weeks ago

Late Posting, Have the update.

Every fine apart from when the Router goes into lag mode.

Doesn't perform to the speeds, give it a reboot and everything is fine again.

I run Networkx monitoring, so I know it needs reboot when I see the graph.

Warning
In participating in this forum you agree not to post or authorise others to post any material that is in our opinion offensive, defamatory, inaccurate, harassing, threatening, invasive of the privacy of others, sexually explicit or illegal. You also agree that you will not post or authorise others to post any copyright material that is not owned or licensed to you. In the event of any breach of this Policy we reserve the right to remove the post without notice to you.

Disabling comments and removing posts
Should we consider a thread or comment in violation of this Policy, we reserve the right to immediately remove part of or entire posts. We also reserve the right to disable, remove or archive posts that have been dormant for 14 days.

Member Login